Хром и Аудио

различные новости по движкам или другим интересным вещам

Сообщение Хром и Аудио
» 12 май 2018, 20:40

Как вы может слышали, а может и нет, с последним апдейтом Хрома изменилось проигрование аудио и теперь звуки не проигрывается автоматически. Трабла в основном с залитыми на порталы играми итд Что бы появился звук иногда надо несколько раз рефрешить итд итп. Скира в новых версиях Construct2 и Construct3 эту траблу решила. Плюс как я понимаю и игровые порталы пытаются как то это решить итп.
Я в начале думал у меня проблемы, потом заметил что все мои игры от тех что проданы до просто залитых на битбаллун не проигрывают звук (причем трабла на Хзроме и Эйдже, на Мазиле все пока ОК)
Вот так же ссылка на блог Эшли где обсуждается данная тема https://www.construct.net/il/blogs/ashleys-blog-2/how-browsers-should-handle-autoplay-restrictions-954
Изображение Изображение Изображение
Аватара пользователя

Игродел
Сообщений: 1273
Я тут с 25 ноя 2014
Откуда: TLV
Двиг: Construct 2
Лицензия: Personal
Репутация 150 [ ? ]

Сообщение Хром и Аудио
» 13 май 2018, 09:20

Заметил это вчера, когда комбинировал звуки на GameJam, но сначала думал, что запустятся после "включения" пользователем (без автоплея, только после клика, ка нельзя сделать автопереход по ссылке), потом думал это из-за того, что звуки слишком короткие. Сейчас потестил музыку - рефреши не помогают.
Сегодня оценивание игр GameJam#3. Если будут проверять в Хроме, то могут всем заминусить за отсутствие музыки. Так что новость вовремя :good:
Аватара пользователя

Модератор
Сообщений: 2650
Я тут с 18 сен 2015
Откуда: Екатеринбург
Двиг: Construct 2
Лицензия: Personal
VK: id21590703
Репутация 393 [ ? ]



Вернуться в Новости

Сейчас эту тему просматривают

Зарегистрированные пользователи: нет зарегистрированных пользователей

Наверх